Make your own free website on Tripod.com

How do I make the speech engines work with Microsoft Agent in Windows XP?

Microsoft Agent uses SAPI 4.0 to provide speech services. Windows XP however now ships with SAPI 5.0 which does not provide backward compatibility support for its predecessor. Fortunately, SAPI 4.0 and SAPI 5.0 can co-exist together on the same Windows XP computer.

To make the speech engines work with Microsoft Agent in Windows XP, first install the SAPI 4.0 runtime binaries (available at
http://activex.microsoft.com/activex/controls/sapi/spchapi.exe), then install the particular speech engines. Note, you may need to follow these procedures even if the SAPI 4.0 runtime and SAPI 4.0 speech engines have previously been installed on a computer being upgraded to Windows XP.